The following error is shown whenever there is a compatibility issue between Thea for Cinema 4D and Cinema 4D itself.

Error: plugin (TheaCinema4D.cdl64) doesn’t support the required sdk

All that you have to do is to make sure that you are using the latest Cinema 4D version.